=============================================================
【提交参数说明】
=============================================================

*****************
动态更新IP:
*****************

提交地址:
http://ddns.21gz.net/ddns.aspx

提交参数:
record:域名,必填
password:密码,必填
ip:域名A记录的ip,留空或非IP格式则自动获取提交端IP地址

GET:http://ddns.21gz.net/ddns.aspx?ip=192.168.1.1&record=test&password=123
POST:demo


域名:.21gz.net
密码:
域名IP:



*****************
获取提交端IP:
*****************

提交地址:
http://ddns.21gz.net/ip.aspx


*****************
修改密码:
*****************

提交地址:
http://ddns.21gz.net/password.aspx

提交参数:
record:域名,必填
oldpassword:旧密码,必填
newpassword:新密码,必填

GET:http://ddns.21gz.net/password.aspx?newpassword=1234&record=test&oldpassword=123
POST:demo


域名:.21gz.net
旧密码:
新密码:



*****************
注册域名:
*****************

提交地址:
http://ddns.21gz.net/create.aspx

提交参数:
record:域名,必填
password:密码,必填
ip:域名A记录的ip,选填
owner:域名所有人姓名,选填
email:域名所有人email,选填

GET:http://ddns.21gz.net/create.aspx?record=test&password=123
POST:demo


域名:.21gz.net
密码:
域名IP:
姓名:
Email:



=============================================================
【提交返回说明】
=============================================================

*****************
成功返回:
*****************

[成功]xxxxxx

*****************
失败返回:
*****************

[失败]xxxxxx


=============================================================
【应用举例】
=============================================================

*****************
CURL:
*****************
curl -k -X POST http://ddns.21gz.net/ddns.aspx -d "ip=192.168.1.1&record=test&password=123"

*****************
Mikrotik(ROS):
*****************

#DDNS域名
:local record "test"
:local password "123"
:global current;

#获取当前拨号的外网IP
:local now [/ip address get [find interface="pppoe-out1"] address];

#判断当前IP与之前的IP是否一致
:if ($now != $current) do={

    #日志输出改变前后的IP
    :log info "ip address $current changed to $now";
    :set current $now;

    #截取真实IP,去掉子网掩码
    :local ip [:pick $now 0 [:find $now "/"]]
    :log info "IP address string: $ip "

    #拼接请求地址
    :local url "http://ddns.21gz.net/ddns.aspx\?ip=$ip&record=$record&password=$password";
    /tool fetch url=("$url") mode=http keep-result=no
    :log info "URL: $url"
}

=============================================================
【软件下载】
=============================================================

本地下载
版本:2.05 支持IIS虚拟主机
安装:请参考《部署说明》